Partial unavailability of Partners API
Incident Report for Salt Edge
Postmortem

Partial service outage on September 3rd, 2024

Incident summary: on September 3rd, 2024, Salt Edge experienced a partial outage that affected the Partner Account Information and Partner Payments Initiation APIs.

Root cause: the outage was caused by the database system reaching an internal limit, that temporarily restricted access to certain services.

Resolution: our team successfully resolved the issue at 10:42 UTC on September 3rd, 2024.

All Connections that missed automatic refreshes have been refreshed.

All Payments scheduled for background refresh were refreshed afterward.

Action Points:

The existing metrics are under investigation to timely detect and prevent such issues in the future.

The data usage and access patterns are being reviewed to minimize the impact of anomalies.

Posted Sep 03, 2024 - 13:02 UTC

Resolved
We are pleased to inform you that the partial outage has been resolved at 10:42 UTC, and all services are now back on track.
Thank you for your patience and understanding. We apologize for the inconvenience.
Posted Sep 03, 2024 - 10:46 UTC
Identified
The issue has been identified and our team is actively working on it.
Posted Sep 03, 2024 - 08:20 UTC
Investigating
At 02:20 UTC, one of our databases encountered an error, resulting in partial unavailability of our API.
Our team is actively working to resolve the issue.
We apologize for any inconvenience this may have caused and appreciate your understanding.
Posted Sep 03, 2024 - 06:52 UTC
This incident affected: Open Banking Gateway (Partners API).