Partial unavailability of Partners API
Incident Report for Salt Edge
Postmortem

Partial service outage on July 31st, 2024

Incident summary: on July 31st, 2024, Salt Edge experienced a partial outage that affected the Partner Account Information and Partner Payments Initiation APIs.

Root cause: the outage was caused by the database system reaching an internal limit, which temporarily restricted access to certain services.

Resolution: our team successfully resolved the issue at 19:57 UTC on July 31st, 2024.

All Connections that missed automatic refreshes between 12:00 UTC and 20:00 UTC on July 31st, 2024, have been refreshed.

Action Points:

  • The existing metrics are under investigation to timely detect and prevent such issues in the future.
  • The data usage and access patterns are being reviewed to minimize the impact of anomalies.
Posted Aug 01, 2024 - 08:42 UTC

Resolved
We are pleased to inform you that the partial outage has been resolved at 19:57 UTC, and all services are now back on track.
Thank you for your patience and understanding. We apologize for the inconvenience.
Posted Jul 31, 2024 - 20:11 UTC
Update
We are continuing to work on the fix. The restoration has reached 51%
Posted Jul 31, 2024 - 19:48 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 31, 2024 - 13:11 UTC
Update
We are continuing to investigate this issue.
Posted Jul 31, 2024 - 12:35 UTC
Investigating
At 11:26:38 UTC, one of our databases encountered an error, resulting in partial unavailability of our API.
Our team is actively working to resolve the issue.
We apologize for any inconvenience this may have caused and appreciate your understanding.
Posted Jul 31, 2024 - 12:07 UTC
This incident affected: Open Banking Gateway (Account Information API, Partners API).