Incident duration: From August 21st, 9:27 in UTC Until August 21st, 9:37 in UTC
All services are now operating normally. Our team continues to monitor the system to ensure stability. We appreciate your patience and understanding.
Posted Aug 21, 2026 - 09:57 UTC
Monitoring
Our affected services have been restored and are currently operational. We continue to monitor the situation, while the data center provider is still working on the underlying network incident.
Posted Aug 21, 2026 - 09:46 UTC
Identified
We are currently experiencing service unavailability caused by a network infrastructure issue at our data center provider. The issue has been identified by the data center provider and their engineers are currently working on resolving it. Our team is monitoring the situation and we will provide an update as soon as more information becomes available.
We apologize for the inconvenience.
Posted Aug 21, 2026 - 09:45 UTC
Investigating
We are currently investigating an issue affecting Open Banking Gateway and Open Banking Compliance.
Customers may experience failed requests. The issue started at approximately August 21st 09:27
Our engineering team is actively investigating the cause and working to restore normal operation as quickly as possible.
Next update will be provided as soon as more information becomes available.
Posted Aug 21, 2026 - 09:41 UTC
This incident affected: Open Banking Gateway (Account Information API, Payments API, Partners API, Dashboards), PSD2 Compliance (Website and dashboards, APIs, TPP Verification, Sandboxes), SCA Solution (SCA Service, Push Service), Compliance Hub (Developer Portal & Dashboards, OpenFinance API, Sandboxes), and Data Enrichment.