Temporary service disruptions

Incident Report for Salt Edge

Postmortem

Incident summary: on January 25, 2025, between 12:33:46 UTC and 12:41:46 UTC, Salt Edge experienced a partial outage affecting the Account Information API and Partners API.

Root cause: the outage was caused by an unexpected database restart, which subsequently triggered a malfunction in the callback delivery service, leading to its increased workload and delays in callback delivery.

Resolution: the issue was successfully resolved by our team at 18:41 UTC on January 25, 2025. All enqueued callbacks were successfully delivered by 00:30 UTC on January 26, 2025.

Action Points:

  • Investigate the database systems to detect and address random restarts proactively.
  • Improve the reliability of the callback delivery service and prevent similar issues in the future.
Posted Jan 27, 2025 - 15:40 UTC

Resolved

The issue has been resolved.
Posted Jan 25, 2025 - 18:41 UTC

Identified

The affected service is Callbacks, the problem is identified, and we’re doing our best to start sending callbacks properly as soon as possible
Posted Jan 25, 2025 - 18:05 UTC

Investigating

We experienced a temporary issue affecting the availability of our services, and some customers may have encountered HTTP 500 Internal Server Errors during the following timeframe:

Downtime start: 25-01-2025 12:33:46 UTC
Downtime end: 25-01-2025 12:37:46 UTC

The problem has been identified and resolved, and all systems are now functioning normally.

However, users may still be unable to proceed to the final stage. Please refresh the page to ensure the issue is fully resolved before continuing.
Posted Jan 25, 2025 - 17:59 UTC
This incident affected: Open Banking Gateway (Account Information API, Partners API).