Open Banking Gateway - Major Outage

Incident Report for Salt Edge

Resolved

The services are now operating normally. Our team continues to monitor the system to ensure stability.

Incident duration:
From May 21st, 12:23 in UTC
Until May 21st, 13:32 in UTC

Maintenance work will be scheduled to further mitigate the issue in about 12 hours, and an announcement about it will be published shortly.

A detailed postmortem containing all relevant information will also be published.

We appreciate your patience and understanding.
Posted May 21, 2026 - 15:23 UTC

Monitoring

A fix has been implemented and services are recovering.

We are currently monitoring the system to ensure that the Open Banking Gateway is operating normally.

Customers may experience minor delays while the system fully stabilizes.

We will confirm once the incident is fully resolved.
Posted May 21, 2026 - 13:38 UTC

Identified

We have identified the cause of the issue affecting the Open Banking Gateway.

At this time, customers may still experience failed requests.

Our team is implementing mitigation measures to restore full functionality.

We will continue to provide updates as progress is made.
Posted May 21, 2026 - 13:02 UTC

Update

We are continuing to investigate this issue.
Posted May 21, 2026 - 13:00 UTC

Investigating

We are currently investigating an issue affecting Open Banking Gateway.

Customers may experience failed requests.
The issue started at approximately May 21st, 12:23 in UTC.

Our engineering team is actively investigating the cause and working to restore normal operation as quickly as possible.

Next update will be provided as soon as more information becomes available.
Posted May 21, 2026 - 12:44 UTC
This incident affected: Open Banking Gateway (Account Information API, Payments API, Partners API).